Error al cotizar el monto del viaje en la plantilla de uber

tengo un problema… en mi plantilla… no se refleja el precio modificado, en el precio total del viaje! no coincide con lo que le modifico… ni siquiera la tarifa minima, alguien que me ayude?

Prueba con esto, fue un comentario que le deje a otro usuario:

Ya encontré el problema, sucede que para operar una App, tu necesitas tener una API key de google maps para poder utilizar los servicios de los mapas, en las plantillas nosotros les ponemos una de prueba, pero esa de prueba al ser utilizada por muchos presenta inestabilidad, al final, siempre tendrías que adquirir tu propia Api de Google Maps, probé con otra distinta y ahí si arroja la tarifa, debes de seguir estos pasos para generar tu API que estará vinculada a tu proyecto: Paso a paso de como obtener tu API key de Google

1 Like

Para usar esta clave en tu aplicación, debes transferirla con el parámetro key=API_KEY). ya tengo la clave, en el console de cloud me sale eso. como debo copiarla?

ya cree mi api key y la copie en las 3 apps del proyecto pero me sigue tirando la misma tarifa! hay alguna otra cosa que tenga que chekear?

creo que no es el problema con la api sino alguna config de la app, por que me tira montos dependiendo del destino y del origen, pero son pequeños alrededor de $30.43 o $31,33 por dar ejemplos, es como si no tuviera en cuenta los parametros que le pongo en el cloud database editor, tendra algo que ver el formato de moneda?

Entiendo, pensé que tu problema era que no se veía la tarifa, pero al parecer si se ve pero no como deseas. Tienes que tener en cuenta que como se calcula la tarifa es por medio de un calculo de distancia entre un punto A y un punto B, esa distancia se multiplica por un Costo por KM, y si ese resultado es menor a la tarifa mínima, lo que te debe de mostrar es la tarifa mínima.

Estas teniendo todas esas consideraciones en los cambios que están haciendo?

si eh probado incluso sin poner la tarifa minima, y me tira montos que no son los adecuados, tendra algo que ver que aun no hice la compilacion?

sera algo de las config de ahi?

compile las app para probarlas y todo iba bien, pedi un taxi, acepte el viaje desde la app del driver, finalize el viaje, pero en una de las pantallas me salia el valor de monto del viaje en MXN sera ese el motivo? del valor de la moneda?

otro problema que me surgio luego que al querer intentar probar otro viaje, en la app del driver no puedo dejar el boton activo, se me cambia inmediatamente. a inactivo, como pudo pasar si ya habia probado la app y el proceso del viaje estubo bien exepto el monto del valor! ayuda!

Soy yo o en la tarifa inicial tienes escrita la letra “O” en vez de un cero? Revisa si ese es el problema. Y no agregues otros registros de mas de configuraciones, ya que solo funciona con la primera fila, que es la que tiene el 0 como identificador. Prueba haciendo esas correcciones

esta solucionado eso necesito ayuda con el boton salir de la app de usuario me tira error y no me sale…

me ayudarias con eso?

Revisa que funciones tienes en el On Press del botón salir, has de tener algún Replace Scree que no tiene seleccionada la pagina de destino, a eso se debe el error que te arroja.