Stripe "no such customer: 'unidefined' "

Hola buen dia, estoy intentando registrar una tarjeta pero me aparece el siguiente mensaje en stripe
{
“error”: {
“code”: “resource_missing”,
“doc_url”: “https://stripe.com/docs/error-codes/resource-missing”,
“message”: “No such customer: ‘undefined’”,
“param”: “customer”,
“type”: “invalid_request_error”
}
}

Se crea el cliente pero sale en blanco todos los compos

Ese error “no such customer” está relacionado a que stripe no recibe un id de cliente desde apphive. Puede ser porque:

  1. Estás cargando la aplicación sin haber iniciado la sesión o Login; sea desde correo, Gmail o Facebook.
  2. El inicio con facebook puede tener algún problema.

Verifica que le estés enviando un id de cliente valido, por que ahí dice que es indefinido lo que le estas enviando.

Puedes consultar las respuestas que se dieron en el siguiente Post relacionado a este: Error al guardar tarjetas en Stripe

La app de apphive la abro desde cuenta de correo y tambien acabo de crear un usuario de el desarrollo de mi app sin cuenta de facebook y aun asi aparece un error

En el codigo de stripe el mes y año me lo marca en rojo, algo tiene que ver?

Al seguir este video, al visualizar tu dashborad de errores, no te aparece otro mensaje que te de mayor claridad del error?

Si claro, este es como tal, la pantalla completa

Si, es que con esa vista se lee cual es el problema que te arroja Stripe, y ahi dice que el problema es con el parámetro de customer. Si el problema fuera del mes o del año, te diría que el parámetro seria Exp_month o Exp:year, pero en este caso el problema es con el customer. Verifica si el id Stripe le esta llegando correctamente cuando haces esa solicitud

Esto me arroja en la opcion de registros en stripe en la opcion de customers

Pero ese es un registro con éxito no? Técnicamente ese registro esta bien, ya que tienes 200OK. Donde debes de ir a buscar lo de customer no es aquí en Stripe, si no en tus funciones, identifica con que llamado te da ese error, y en esa función has de tener algún id usuario, donde le mandas el id Stripe, y ese id Stripe pueda que se esta mandando vacío, o sea un valor invalido, como te dice el mensaje de error.

Ya revise todo nuevamente, estoy siguiendo el tutorial tal cual en youtube y no le he podido encontrar falla
Incluso borre todo y lo volvi a hacer varias veces

A donde marca el error al parecer es en este paso

El problema que veo, es que el valor que regresa Apphive no se manda bien y no se registra correctamente en Stripe ya que no manda los valores del correo y nombre

Aqui esta donde agrego el campo mediante “Set user custom data” (cambie de nombre de stripe id a stripeid)

Y aqui esta donde lo asigno a la tarjeta tokenizada

Otra duda que tengo, es que al momento de consultar los usuarios registrados, no sale este campo adicional, no se si se tengan que crear los campos o solo los podamos consultar con “user custom data”

Hola @Angel_Herrera_Camari, saludos!

Observando la imagen que me compartes, donde muestra que se están creando los usuarios pero los campos los envía en blanco, podría deducir que cuando haces la prueba, no tienes una sesión iniciada, y por eso el email y name que le envías a la función de Created a customer no tienen valor, y se crean con valores vacíos, y de aquí es de donde se derivan los demás errores.

Haz las pruebas respectivas, que cuando hagas la prueba de crear un usuario, tengas una sesión iniciada dentro de la App. Si no lo que puedes hacer también, para ver que si le esta enviando valores esa función, es colocar datos directos, escritos por ti en los campos, y al crear el cliente, te tendría que aparecer en ese panel.

1 Like

Listo, ya quedo, muchas gracias!

Genial, al final cual era el problema? Por si a alguien mas le sucede lo mismo, puede leer la solución que le diste por acá.