Problema "Save data in db" comentarios

Al momento de guardar un comentario de un PostA, no guarda con el ID del PostA (disponible en PageData>PostID) que le asigné.

En lugar de esto restablece el valor a uuii en el momento de ejecutar la acción, lo que imposibilita crear el UI Collection, y filtrar por los comentarios que tengan el mismo ID del PostA.

  • Variable PostID enviada desde el UICollection>ItemID de la página “Feed” y declarada en la página “Comentar”.

Tendrás una captura de la base de datos en el guardado para ver como se ve?

Aquí muestro bien @Jonatan https://www.loom.com/share/ae8b747db41840b7b85d554e92adc784

@Jonatan Solucionado. Empecé desde cero la parte de comentarios y todo marchó correctamente.

1 Like

Buenos días… Amigo, tengo un problema similar, en la primera tabla me crea un registro con toda la información, y adicionalmente me crea un registro vacío (que solo contiene el id de registro), adjunto a ese registro vacío se encuentran los datos de la tabla dependiente. Llevo una semana tratando de resolverlo. Si lo resolviste te agradezco que me puedas ayudar. Feliz día.

Buenos días Jonatan, no sé si es que no he buscado bien, pero no encuentro un instructivo ni escrito ni en video donde muestre cómo guardar datos cuando tienes una colección dentro de otra, me está sucediendo que en la primera tabla me crea un registro correcto con la información correspondiente a esa tabla, pero no muestra los datos de la colección que está adentro. Solo que enseguida ha creado otro registro vacío que solo contiene el “id de registro” y a ese si se encuentra adjunta la colección dependiente con la información que se mandó a guardar. ¿Por qué se crea ese doble registro? Agradezco tu pronta respuesta.

Hola @Ricardo, saludos.

Puedes compartirme un video con la plataforma de “loom” para poder ver como estas guardando xfa, y poder ayudarte mejor