Problema en el Splash Screen

¡Hola a todos!
Tengo un problema.
En el previulizador de Apphive no me da este error.
Lo que pasa es que en el apk inicio sesion la primera vez y todo normal, despues cierro y simplemente se queda en el splash.
Adjunto mi app y video para que vean a que me refiero


https://editor.apphive.io/editor/proj_pkwyifQYKCQv1yntuoHoNw/app_qBTkAaX7upDC5kxGS2rsMr/pages/insert/page_rHvRHpC4zwggzvWamE5P4A/page_rHvRHpC4zwggzvWamE5P4A/functions

1 Like

El problema esta aquí, cuando lees la versión de la aplicación en el Get database data, no has pasado esos datos a tu base de datos de producción, solo los tienes en tu base de datos de prueba, por lo que el get database data se va por el empty, y ahí se queda trabado.

Base de datos de producción:

Base de datos de prueba:

Para agregarlos, solo ingresa a tu base de producción activando el Switch, cuando te aparezca en rojo, sabrás que estas en producción.

2 Likes

Eso me ayudaron en soporte tecnico (Mario) el poblema era que no tenia datos en la base de datos de produccion

Hola @Josue_Abrego_Soriano @Jonatan
Tengo el mismo problema y mi proyecto aún no está en producción. Antes de la última actualización todo funcionaba perfecto y ahora al entrar a la app del mensajero se queda en el splash igual que le sucede a @TheAndroits. Sabes a qué se debe esto? Gracias!!

En el caso de @TheAndroits, el problema era que en el Splash estaba leyendo el numero de versión que tiene la aplicación, para luego mandarlo a una ventana que mostrara que necesita descargar la actualización. El problema era que el Get donde consultaba el numero de versión, al menos en la base de datos de producción no tenia ningún dato, por lo que el Get database data se iba por el Callback de Empty, lo que ocasionaba que se quedara trabado en esa parte al no tener ninguna acción en eses Callback.

Muy probablemente este pasando lo mismo, que en la lógica de redirigir usuario o en la lógica que tengas en el Splash, se este yendo por algún camino que no tiene salida, intenta colocar mensaje en todos los Callback, tanto en los errores o Empty de tus procesos para identificar donde esta el error

Tengo exactamente el mismo problema

1 Like

Hola @oscar_otero, pudiste encontrar cual era el problema?

Si, a todo el que presente problema que en el Apk no le pasa del Splash, es por que hay información que no se ha pasado de pruebas a producción, y justo en el Splash hay un Get database data, y ese Get al no encontrar información en la base de datos de producción se va por Empty, y en empty no suele tener funciones, por eso se queda pegado de esa manera.

me esta pasando eso las 4 apk se quedan pegados al momento de probarlos en mi android como lo soluciono

Hola @jose_riascos , saludos.

¿Aun presentas el problema de los Splash que comentas?

Si sigues presentando problemas, te invito a que escribas al chat de soporte, presentes tu inconveniente y con gusto abriremos un ticket con tu problema para revisarlo y darle seguimiento hasta que quede resuelto.