Problema con el mapa al crear los marcadores y centrado

Hola buenas noches.
Estoy precisando ayunda.
Tengo un problema con el mapa, el tema es que cuando entro a la aplicacion el mapa esta en la localizacion correcta pero al poner el origen o el destino el mapa se va para mexico.
esto ocurrio despues de hacer los modify control de los marcadores de origen y destino y el centrado del mapa, los marcadores igual nunca aparecieron y al borrar tanto los marcadores como el centrado vuelve aparecer el mapa correcto.
Cual sera el error?
si me pueden ayudar les agradezco mucho.

Es muy probable que no le estés enviando correctamente la latitude y la longitude en las variables de pagina al mapa, ya que cuando detecta que están mal esas variables, te muestra la ubicación default que tiene el mapa, y justamente es la que te sale de mexico.

Para solucionarlo, coloca Alert en la ventana del mapa, para leer esas variables que estas mandando, y ver si en verdad les mandas valor alguno

Genial… Gracias voy a intentar eso.
porque reviso y no envuentro el error.
si no soluciono vuelvo a preguntar.
Muchas gracias.

Haz la prueba, y nos comentas el resultado

Hola buenas tardes!
puse el alerta en el mapa y me da la latitud y longuitud correcta pero no genera los marcadores y el mapa queda sin movilidad

y tambien me paso esto despues de poner los marcadores y el centrado del mapa.


los cuales los borre y anduvo bien nuevamente.

Como estas mostrando la información en el mapa? Puedes grabar un video con la plataforma de “loom” para ver que información le estas mandando xfa, ya que lo que muestras en el Alert por lo visto es una lectura de un Get local storage, quiero ver como estas mostrando esa información por medio de los Modify Controls

Hola buena tardes Josue.
ante todo quiero agradecerte por responder mis consultas.
Dejo el enlace del video
https://www.loom.com/share/2a22e57ddf654333806d1cda7d723d72

Hola @Santiago_Perez, de hecho lo que necesitaba era ver como estas mostrando la información de los marcadores en el mapa, sin eso no puedo ayudarte mucho ya que era ese el problema que presentabas

pense que era donde estaba haciendo el alert.
dejo otro enlace con el video de los marcadores y el centrado del mapa.https://www.loom.com/share/d25546639efd4cf3bef482ec5be895bb

Puedes compartirme nuevamente el enlace al video, cuando ingreso, solo veo en blanco la parte del video

comparto el enlace nuevamente

https://www.loom.com/share/d25546639efd4cf3bef482ec5be895bb

El problema esta en que estas utilizando mal la lógica para mostrar un marker, un marker se muestra enviando al mapa una latitude y longitude, no una dirección como lo estas haciendo.

En Origin data si pones una latitude, modificas el mapa, en la propiedad del Marker, y donde has puesto origen y destino en la parte de abajo, debe de ir el nombre del marcador, con la palabra latitude. En el video se debe de mostrar la configuración que lleva el Modify para mostrar el marcador

Bien intente pero creo que no lo hice bien.
SERIA ASI:

Data to send
Get local storage data[origen.latitud]
Element
[map]Map
Property to modify
markers
Property to modify
origen.latitud

lo mismo con la longitud y tambien realice lo mismo en destino y no funciono.
tambien intente colocando en Data to send Get local storage data latitud y con longitud y nada.
y en esta parte Property to modify
markers ( en ves de modificar los markers intente poniendo region latitude y region longitude y nada asi que si estoy haciendo algo mal

Si, el problema es que en la base de datos tienes guardado latitud en vez de latitude, le hace falta la “e” al final, y Jonatan hace énfasis en la importancia que se llame así para que funcione como lo hace el

genial josue ya modifique eso en la base de datos y se soluciono.
muchas gracias

A la orden amigo…!

1 Like