Error al calcular distancia

Toda al app funcionaba pero al agregar el API KEY de Google me sale este error.

Ya revisaste nuevamente el proceso?

A mi paso algo parecido pero era por el API key de google que tenia que actualizarlo
Aca me dieron esta respuesta y me soluciono el problema

Hola, durante nuestra actualización al momento de crear una app que necesite mapas deberas utilizar las Google API keys de la cuenta por usuario, siguiendo este tutorial podrás cargarlas tu mismo:

Tutorial 1: https://www.loom.com/share/7e784c85887846248ab33c7fee33c286

Tutorial 2: https://www.youtube.com/watch?v=JFQ8sF1G-7Q&t=684s

Activación obligatoria:

-Directions API
-Distance Matrix API
-Maps JavaScript API
-Maps SDK for Android
-Places API
-Geocoding

Google tiene una capa gratuita de $200 USD al mes, por lo que no tendrás que pagar hasta que la superes, como referencia el Geocoding cuesta 4 USD / 1,000 consulta

Nota: el proceso de Background Geolocation License Key, solo sera necesario al momento de la publicación a tiendas

*activa tu metodo de pago para que se active la Google API key.

1 Like

Alguien me ayuda tengo el mismo problema como solucionarlo? :exploding_head:

Saludos @Ikkoa

Para poder dar con el problema, te recomiendo que busques en tu lógica donde esta ese Alert que manda con ese mensaje, luego grabas un video con la plataforma de “loom”, en donde expliques como tienes la lógica para calcular la distancia, así será más fácil el poder ayudarte

También debes de verificar que los datos de coordenadas que le estás mandando a la función sean correctas, esto lo puedes probar buscando en google maps algunos puntos y meter las coordenadas de forma directa, pero asegúrate de que las coordenadas sean de un lugar en especifico, no de un área